Issue
When installing AutoCAD 2023 or another program, you encounter the following Error 4005 "the install couldn't finish" error:
Cause
Corrupted On-Demand Installation Service (ODIS) installation or a connection issue such as Antivirus/Firewall/Proxy/ VPN (Virtual Private Network) preventing ODIS component from reaching out to the Internet.
This is a critical component of newer installation packages.
Affected Software
AutoCAD 2023+
Resolution
Before you begin, delete all data in the following folders:
C:\Autodesk\WI\
C:\Users\%USERPROFILE%\AppData\Local\Autodesk\ODIS\
C:\Users\%USERPROFILE%\AppData\Local\Temp\
C:\Program Files\Autodesk\AdODIS\V1
Note: If these folders aren't present, it's been blocked from installation and is network/security-based rather than corrupt.
- Manually download and install ODIS from this link.
- Run the installation as an admin.
- Retry the AutoCAD installation.
Alternative Resolution
- Start Menu > Command Prompt (Run as administrator)
- Type the following command, replacing the bolded section with the correct path to your installation:
cd C:\Autodesk\AutoCAD_2022_English_Win_64bit_dlm\
- Press Enter
- Copy and paste the command below, then press Enter:
Setup.exe --noupdate
Related Articles:
- "An error occurred while preparing the installation" when installing an Autodesk product
- “AutoCAD 2023 The install couldn’t finish. Error 4005” when installing AutoCAD-based 2023 products
- Which URLs/Protocols need to be allowed for Autodesk Subscription Licensing
Contact Support
If you are still experiencing issues or have further questions, please reach out to our support team Monday through Friday, 8:00 AM—5:00 PM EST:
- 📧 Submit a Request
- 📞 (703) 924-5310 or Schedule a Call
Related to: