Troubleshooting Error 4005 During Installation Troubleshooting Error 4005 During Installation

Troubleshooting Error 4005 During Installation

Eden Davis Eden Davis

Issue

When installing AutoCAD 2023 or another program, you encounter the following Error 4005 "the install couldn't finish" error:

Cause

Corrupted On-Demand Installation Service (ODIS) installation or a connection issue such as Antivirus/Firewall/Proxy/ VPN (Virtual Private Network) preventing ODIS component from reaching out to the Internet.

This is a critical component of newer installation packages.

Affected Software

AutoCAD 2023+

Resolution

Before you begin, delete all data in the following folders:

C:\Autodesk\WI\
C:\Users\%USERPROFILE%\AppData\Local\Autodesk\ODIS\
C:\Users\%USERPROFILE%\AppData\Local\Temp\
C:\Program Files\Autodesk\AdODIS\V1

Note: If these folders aren't present, it's been blocked from installation and is network/security-based rather than corrupt.

  1. Manually download and install ODIS from this link.
  2. Run the installation as an admin.
  3. Retry the AutoCAD installation.

Alternative Resolution

  1. Start Menu > Command Prompt (Run as administrator)
  2. Type the following command, replacing the bolded section with the correct path to your installation:
cd C:\Autodesk\AutoCAD_2022_English_Win_64bit_dlm\
  1. Press Enter
  2. Copy and paste the command below, then press Enter:
Setup.exe --noupdate 

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