Issue
Some or all Autodesk and Bluebeam Products and versions experience fatal errors. There may be an issue loading specific .dll / assemblies.
If an error report can be generated, check the details of the error report for the log locations and debug with Visual Basic to see if a component is being blocked:
Cause
General security/permissions protocols.
Specifically, AppRat procedures or changes — a list of applications are targeted for removal and placed on all CEC customer systems, and a script is deployed that goes through the list to uninstall an application if it is present on the system.
Confirm if components/applications are being removed by reviewing .msi uninstall logs (location may vary).
See below example:
Confirm it is not a licensing/installation issue.
Review the debug.log file from the Network License Manager:
Check ODIS logs to confirm the issue is not installation or licensing-related.
Affected Software
Some or all Autodesk and Bluebeam Products and versions in a highly secure environment.
For example: Civil 3D 2020, Civil 3D 2022, Bluebeam Revu 20
Resolution
Have your IT pause any security procedures and review the configurations to ensure there is no impact on Autodesk or Bluebeam software.