"The install couldn't finish. Error -9" when installing Autodesk 2022 or above version products "The install couldn't finish. Error -9" when installing Autodesk 2022 or above version products

"The install couldn't finish. Error -9" when installing Autodesk 2022 or above version products

Lance Edwards Lance Edwards

Issue

While installing an Autodesk 2022 product or the above, the following message appears

 

Install error: <Product Name>

The install couldn't finish.
Error -9

 

 

Cause

Checking on the Install.log in %localappdata%/Autodesk/ODIS, the installation failure is due to an issue while installing Microsoft DirectX.

 

Fail when performing Installation of (upi2: {C9D7C6BF-A352-3EE7-AF06-BFE6D5507BED} name: Microsoft DirectX for Windows )

Affected Software

All Desktop Products 2022

All Desktop Products 2023
 

All Desktop Products 2024

 
 

Resolution

To try to fix the issue, try the following before reattempting the installation

 

Note:

Update of Direct X may result in Revit not reporting the current hardware certification status. You may need to update the Autodesk XML hardware certification file.

Autodesk Revit Hardware Certification FAQ

 

 

Contact Support

If you are still experiencing issues or have further questions, please reach out to our support team Monday through Friday, 8:00 AM—5:00 PM EST: